PDA

View Full Version : Demo font bug?


Dunqan
09-12-2007, 10:49 PM
Just downloaded the demo bug when I run it I get a red screen with what looks like an attempt at rendering a font but just has little blocks instead. I'm re-downloading the demo from another site incase it's somehow corrupted but not sure.

Dunqan

Dunqan
09-12-2007, 11:17 PM
Tried rebooting but no help - the pages just aren't rendering properly for some reason - haven't had any issues with any other games before. Playing on a Thinkpad T42p.

Dunqan

Dunqan
09-12-2007, 11:51 PM
Looks like it's having trouble finding textures, etc. (even after a re-install) for some reason - here's the log file:


Initializing networking
RPG Version 0.881

Couldn't find Textures/black.rtx
Couldn't find Textures/white.rtx
Couldn't find Textures/circle.rtx
Couldn't find Textures/x.rtx
Couldn't find Textures/plus.rtx
Couldn't find Textures/minus.rtx
Couldn't find Textures/emptyTile.rtx
Couldn't find Textures/UI/gradiant_white.rtx
Couldn't find Textures/shadow.rtx
Couldn't find Textures/noise.rtx
Couldn't find Textures/Fonts/Arial12.rtx
Couldn't find Textures/Fonts/Arial16.rtx
Couldn't find Textures/Fonts/Arial20.rtx
Couldn't find Textures/Fonts/Arial24.rtx
Opened Generic Software Device
Using 256 sound sources
Sound system initialized
Couldn't find Textures/UI/up1.rtx
Couldn't find Textures/UI/close.rtx
Couldn't find Textures/UI/down1.rtx
Couldn't find textures/ui/gradiant_gray.rtx
Couldn't find Textures/UI/grayhotbar-main1.rtx
Couldn't find Textures/UI/grayhotbar-main2.rtx
Couldn't find Textures/UI/gradiant_blue.rtx
Couldn't find Textures/UI/iconoutline.rtx
Couldn't find Textures/UI/extrahotbrbg.rtx
Couldn't find Textures/outline.rtx
Couldn't find Textures/outlineItem.rtx
Couldn't find Textures/Icons/wonGame.rtx
Couldn't find Textures/icons/stopRaid.rtx
Couldn't find Textures/icons/diplomacyRequest.rtx
Couldn't find Textures/Icons/townBeingAttacked01.rtx
Couldn't find Textures/Icons/townsiege.rtx
Couldn't find Textures/Icons/friendBeingRaded01.rtx
Couldn't find Textures/icons/war.rtx
Couldn't find Textures/icons/beingRaided.rtx
Couldn't find Textures/UI/playername_border.rtx
Couldn't find Textures/UI/plyrhealth_border.rtx
Couldn't find Textures/UI/ui_icons/icon_character.rtx
Couldn't find Textures/UI/ui_icons/icon_house.rtx
Couldn't find Textures/UI/ui_icons/icon_tomes_03.rtx
Couldn't find Textures/UI/ui_icons/icon_bags_satchel.rtx
Couldn't find Textures/UI/ui_icons/icon_map.rtx
Couldn't find Textures/UI/ui_icons/icon_tomes_02.rtx
Couldn't find Textures/UI/ui_icons/icon_covenant.rtx
Couldn't find Textures/UI/ui_icons/icon_mainmenu.rtx
Couldn't find Textures/UI/ui_icons/questAvailable.rtx
Couldn't find Textures/UI/ui_icons/icon_minimap.rtx
Couldn't find Textures/UI/playername_border2.rtx
Couldn't find Textures/UI/minimap/minimap_border.rtx
Couldn't find Textures/UI/shortquest.rtx
Couldn't find Textures/UI/rankingsbg2.rtx
Couldn't find Textures/ui/hotbar_tab1.rtx
Couldn't find Textures/helpBorderUpperLeft.rtx
Couldn't find Textures/helpBorderTop.rtx
Couldn't find Textures/helpBorderUpperRight.rtx
Couldn't find Textures/helpBorderRight.rtx
Couldn't find Textures/helpBorderLowerRight.rtx
Couldn't find Textures/helpBorderBottom.rtx
Couldn't find Textures/helpBorderLowerLeft.rtx
Couldn't find Textures/helpBorderLeft.rtx
Couldn't find Textures/UI/seamlessmarble.rtx
Couldn't find Textures/ui/borders/stripedtopbord.rtx
Couldn't find Textures/UI/borders/leftsidebord.rtx
Couldn't find Textures/UI/borders/rightsidebord.rtx
Couldn't find Textures/UI/borders/bottborder.rtx
Couldn't find Textures/UI/borders/bordercorner.rtx
Couldn't find Textures/ui/button4.rtx
Couldn't find Textures/Logos/GameLogoLeft.rtx
Couldn't find Textures/Logos/GameLogoRight.rtx
Couldn't find Textures/ui/mainmenu.rtx
Couldn't find Textures/ui/mainmenu_rght.rtx
Couldn't find Textures/ui/button5.rtx
Couldn't find Textures/Logos/SoldakLogo.rtx
Couldn't find Textures/UI/cave.rtx
Couldn't find Textures/UI/cave_right.rtx
Couldn't find Textures/ui/loadchar_small.rtx
Couldn't find Textures/ui/lng_buttondrk.rtx
Couldn't find Textures/ui/uibubble6.rtx
Couldn't find Textures/ui/uibubble_down.rtx
Couldn't find Textures/UI/checkbox_uncheck.rtx
Couldn't find Textures/UI/checkbox.rtx
Couldn't find Textures/UI/scrollbar_downarrow.rtx
Couldn't find Textures/UI/dropdown_bg.rtx
Couldn't find Textures/UI/dropdown_menu.rtx
Couldn't find Textures/UI/scrollbar_uparrow.rtx
Couldn't find Textures/UI/scrollbar_leftarrow.rtx
Couldn't find Textures/UI/scrollbar_rightarrow.rtx
Couldn't find Textures/UI/scrollbar_bar.rtx
Couldn't find Textures/UI/scrollbar_backing.rtx
Couldn't find Textures/UI/scrollbar_barHoriz.rtx
Couldn't find Textures/UI/scrollbar_backingHoriz.rtx
Couldn't find Textures/UI/slider_bar.rtx
Couldn't find Textures/UI/slider_notch.rtx
Couldn't find Textures/UI/gradiant_green.rtx
Couldn't find Textures/ui/lng_buttonlght.rtx
Couldn't find Textures/ui/ui_icons/iconslot_rank1_champ.rtx
Couldn't find Textures/UI/monstmark_outline.rtx
Couldn't find Textures/ui/ui_icons/iconslot_rank2_elite.rtx
Couldn't find Textures/ui/ui_icons/iconslot_rank3_unique.rtx
Couldn't find Textures/ui/ui_icons/iconslot_rank4_legend.rtx
Couldn't find Textures/ui/ui_icons/iconslot_rank5_boss.rtx
Couldn't find Textures/UI/charscreen/charscreen_bg.rtx
Couldn't find Textures/UI/plus.rtx
Couldn't find Textures/UI/borders/uiborder.rtx
Couldn't find Textures/UI/borders/centerbord.rtx
Couldn't find Textures/UI/borders/topbord_leftcorn.rtx
Couldn't find Textures/UI/borders/topbord_cutoff.rtx
Couldn't find Textures/UI/ui_icons/iconslot_empty.rtx
Couldn't find Textures/UI/borders/centerbord_horiz.rtx
Couldn't find Textures/UI/borders/topbord_rightcorn.rtx
Couldn't find Textures/UI/iconoutline2.rtx
Couldn't find Textures/UI/ui_icons/iconslot_chest.rtx
Couldn't find Textures/UI/ui_icons/iconslot_weapon.rtx
Couldn't find Textures/UI/ui_icons/iconslot_shield.rtx
Couldn't find Textures/UI/ui_icons/iconslot_helm.rtx
Couldn't find Textures/UI/ui_icons/iconslot_necklace.rtx
Couldn't find Textures/UI/ui_icons/iconslot_shoulders.rtx
Couldn't find Textures/UI/ui_icons/iconslot_cloak.rtx
Couldn't find Textures/UI/ui_icons/iconslot_wrists.rtx
Couldn't find Textures/UI/ui_icons/iconslot_gloves.rtx
Couldn't find Textures/UI/ui_icons/iconslot_belt.rtx
Couldn't find Textures/UI/ui_icons/iconslot_legs.rtx
Couldn't find Textures/UI/ui_icons/iconslot_boots.rtx
Couldn't find Textures/UI/ui_icons/iconslot_ring.rtx
Couldn't find Textures/UI/ui_icons/iconslot_jewelry.rtx
Couldn't find Textures/UI/uibubble2.rtx
Couldn't find Textures/UI/uibubble3.rtx
Couldn't find Textures/ui/ui_icons/icon_kick.rtx
Couldn't find Textures/UI/uibubble.rtx
Couldn't find Textures/ui/questjournal/questjournal2.rtx
Couldn't find Textures/UI/smallcorndec2.rtx
Couldn't find Textures/UI/smallcorndec2_topleft.rtx
Couldn't find Textures/UI/smallcorndec2_right.rtx
Couldn't find Textures/UI/smallcorndec2_topright.rtx
Couldn't find Textures/UI/questjournal/questjournal.rtx
Couldn't find Textures/UI/marbleborder_outline.rtx
Couldn't find Textures/ui/covpower_triangle.rtx
Couldn't find Textures/ui/lrg_rightArrow.rtx
Couldn't find Textures/ui/lrg_leftArrow.rtx
Couldn't find Textures/ui/uibubble_lght_rnd.rtx
Couldn't find Textures/ui/charname_indent.rtx
Couldn't find Textures/ui/loadchar_backdrop.rtx
Couldn't find Textures/ui/iconoutline_decor.rtx
Couldn't find Textures/UI/skillscreen/skillbackground.rtx
Couldn't find Textures/UI/dragedge.rtx
Couldn't find Textures/UI/dragedge_right.rtx
Couldn't find Textures/UI/marbleborder.rtx
Couldn't find Textures/UI/marbleborder_selected.rtx
Couldn't find Textures/close.rtx
Couldn't find Textures/UI/darkmarble2.rtx
Couldn't find Textures/ui/closecorner.rtx
Couldn't find Textures/UI/buttonbackdrop.rtx
Couldn't find Textures/UI/uibubble6_lght.rtx
Couldn't find Textures/UI/uibubble2_drk.rtx
Couldn't find Textures/UI/lrg_uibubble.rtx
Couldn't find Textures/UI/ui_icons/icon_itemslot2.rtx
Couldn't find Textures/UI/ui_icons/icon_itemslotrelic.rtx
Couldn't find Textures/ui/journal_bg.rtx
Couldn't find Textures/ui/marbleborder_outlinedrk.rtx
Couldn't find Textures/ui/minimap/circle2.rtx
OS: Microsoft Windows XP Professional Service Pack 2 (Build 2600)

CPU Type: GenuineIntel
CPU Name: Intel(R) Pentium(R) M processor 1.80GHz
CPU Features: FPU, MMX, SSE, SSE2, CLFL, TSC, CX8, CMOV, VME, DE, PSE, MSR, MCE, SEP, MTRR, PGE, MCA, PAT, FXSR, DTES, SS, TM1
Sound card: SoundMAX Digital Audio
RAM: 1534 MByte!
Input initialized
Debug system started

File System Stats
-----------------
Total Files opened : 13414
Real Files opened : 2
Virtual Files opened : 2902
Bytes read : 4871762
Bytes written : 7994
File log.txt still open
-----------------

Memory System Stats
-----------------
Type - Total
Bytes allocated : 16398600
Max bytes allocated : 19051356
Total allocations : 663885
Total deallocations : 524593
# blocks : 139297

Type - General
Bytes allocated : 14331652
Max bytes allocated : 19051356
Total allocations : 663874
Total deallocations : 524595
# blocks : 139284

Type - Sound
Bytes allocated : 0
Max bytes allocated : 359356
Total allocations : 9
Total deallocations : 9
# blocks : 0

Type - Graphics
Bytes allocated : 29092
Max bytes allocated : 29092
Total allocations : 11
Total deallocations : 4
# blocks : 7

Type - Music
Bytes allocated : 2037648
Max bytes allocated : 2522788
Total allocations : 17
Total deallocations : 12
# blocks : 5

-----------------

Debug System Stats
-----------------
-----------------

UserVar System Stats
-----------------
-----------------

Shadow
09-13-2007, 08:49 AM
It's looking for rtx textures which are the uncompressed versions, which the demo didn't ship with. Does your video card not support compressed textures? What video card do you have?

Dunqan
09-14-2007, 07:55 PM
It has a mobility Radeon in it - here's the basic specs from thinkwiki.org. I'd be surprised if it didn't support compressed textures (if most cards do - although I wouldn't know - but I've never had a problem before).


http://www.thinkwiki.org/wiki/Category:T42

ATI Mobility Radeon 9600
Chipset: ATI RV350 (M10)
PCI ID: 1002:4c66
AGP 4X
32 or 64MB DDR-SDRAM video memory
External VGA up to: 1920x1200

Does the full version of the game download come with uncompressed textures? I'd be willing to buy it based on the good things I've read on Octopus Overlords if it'll likely work.

Dunqan

Shadow
09-14-2007, 10:17 PM
Most graphics cards do support compressed textures. You might want to open User/user.cfg and make sure that compressedTextures is set to 1. If that doesn't fix it, the demo just isn't going to work. The demo has some limitations that rules this out.

The full game does not ship with the uncompressed textures either, but it is supposed to create them if needed. I just tested it though and it isn't working. I'll fix this in the first patch. I believe I'm going to release a beta patch tomorrow sometime that will include this fix along with a few others.

Shadow
09-18-2007, 12:28 PM
I did fix this in 1.001, so it should build the uncompressed textures just fine with that patch applied.

vhan
09-18-2007, 11:13 PM
I have the same problem with demo on Matrox G400.
When I uncompress assets001.zip into Assets directory, the game creates
.rtx files, but don't use it. When I add .rtx files into assets001.zip, the game
don't find Database\database.dbl.
Is there any workaround ?

Shadow
09-18-2007, 11:27 PM
The problem, and this is only a problem for the demo, is that on a graphics card that doesn't support compressed textures you need the rtx files but don't have them, the demo is not allowed to read in any files that are outside of the zips, and no files are allowed to be added to the zip files.

Actually now that I have said all of that, there might be a work around. If you unzip everything and let the game generate all of the rtx files (like you already have), then delete all of the ctx files, and then zip everything backup it might work. What you want to have at the end is the 2 zip files with the same original names and containing the same number of files as they originally did, but containing rtx files instead of ctx files.

vhan
09-19-2007, 12:31 AM
Thanks
It realy works !

MacGuges
01-16-2008, 12:38 AM
I'm relieved to find this thread, because I've wanted to play this game for several weeks, after reading about it at Manifesto. I posted there about this problem. (http://www.manifestogames.com/node/4293) This solution worked for me. (For the developers, my graphics card is a Radeon 9600 PRO.)

I hope the developers can fix this bug, cause the demo was unplayable before.

For the benefit of anybody coming here after me, allow me to repeat the necessary steps:
1) Go to the installation directory, then the Assets sub-directory. (C:\Program Files\Depths of Peril demo\Assets\)
2) Rename assets001.zip to assets001_backup.zip
3) Extract assets001_backup.zip to the current directory. The folders Database through UI will appear in the same directory as the .zip files.
(It's not necessary to do anything with the assets002.zip file.)
4) Run the game. It will fail, and display a single message, about Database\database.dbl.
5) Search for files. Enter *.ctx in the first criteria field "All or part of file name", then drop down Look in:, choose Browse... and select the Assets directory. (or enter C:\Program Files\Depths of Peril demo\Assets\)
6) Click Search. After the results appear, sort by name. Select all of the longer pathname results (I encountered duplicate results, YMMV), beginning with the drive letter. Delete the .ctx files.
7) Return to the Assets sub-directory. Compress its sub-directories into an archive named assets001.zip. I used 7zip, so I selected the folders then chose 7-zip > Add to archive.
8) Run the game; if you get the error message, then you probably missed deleting some .ctx files before recreating the archive. I did. Search again & create a new archive.
(After you can run the game, you can delete the sub-directories and assets001_backup.zip file.)

Now it's time for me to play this thing.