PDA

View Full Version : "Access violation" CTD problem


Corvus Corax
09-15-2007, 05:20 PM
I get a random crash-to-desktop (usually after at least an hour's play). The error msg. reads:

"Access violation at 0x00645A3 (tried to read from 0x00133000), program terminated."

The program's termination does not, however, appear to be complete, as the music continues to run in the background. I restart to get rid of it.

The good news: the program appears to be saving when it "crashes" because if I restart it and "resume" my last play, I don't appear to lose any game progress.

I'm running the game on a P4 3.4 (dual core), 2 gigs RAM, GF6800GT, Audigy 2, XP SP2. My video and audio drivers aren't particularly up-to-date. :o

Shadow
09-15-2007, 05:31 PM
The game automatically saves every 2 minutes, so crashes usually aren't too bad. Were you doing anything in particular when this happened?

Corvus Corax
09-15-2007, 05:59 PM
I had just teleported back to the village after completing a couple of quests. I believe I was heading for the merchant to sell a couple of items (before going to get credit for the quests), but hadn't reach him yet when the error message appeared and the game went to desktop.

It's happened about 4 times so far, starting when my character was about level 8 or so (now 13). I had no problem at all during my first couple of days of play.

Next time it happens, I'll note down exactly what I was doing at the time. As long as I don't lose progress, I don't consider it a big deal.

Corvus Corax
09-15-2007, 07:54 PM
It happened again about a half hour after I resumed play....same error message. I had just teleported back to home base after completing a recruiting mission. I had to replay the recruiting mission (the game restored me to just after I took the mission), but this time it didn't happen when I teleported back (repeated the process exactly to see if I could replicate the error). Played for another hour and no error. One thing I didn't do after the crash is I didn't reboot to stop the music. I just restarted the game. So far the problem just seems random.

Shadow
09-16-2007, 11:02 AM
It really sounds like you might have something slightly broken in your current game. If you zip up your chars directory and send it to me, I'll run your game under the debugger and see if I can track down the problem. Jump over to our contacts page here (http://www.soldak.com/content/blogcategory/19/52/) to get my email address.

Jeff Graw
09-22-2007, 03:00 AM
I get this message whenever I try to run the program

"Error:Access violation at 0x6B8AA69B (tried to write to 0x003E0650), program terminated""

Shadow
09-22-2007, 09:50 AM
You get that crash every single time you run the game now? It is it on startup before you see the menus?

I just now noticed that you edited one of your other posts and had already mentioned this crash. I'm sorry that I missed this.

Does the game even get far enough to ask you for your name and key? If it doesn't you might want to look at the last post in this thread (http://www.soldak.com/forums/showthread.php?t=80&page=2).

Corvus Corax
09-26-2007, 03:14 AM
Good news! Since I installed v. 1.002 two days ago, I haven't had an "access violation" crash. :)

killerbeans
12-12-2007, 08:23 PM
I am having a problem with game crashes. The problem I am having is that I have killed a character named Kurg or something, it's a Unique Large Earth Silt or whatever, the game crashes. I killed him like 3 times, he was part of a group, and every time I killed him, the game crashed. I have also experience random game crashes just for whatever reason. I think the reason that this irritates me the most is because a lot of the times it crashes, I am headed for a "unique" weapon or piece of armor, it sometimes just crashes. I have no idea what I am doing wrong or what is wrong with the game, but it just crashes... Any suggestions? It doesn't seem to matter whether or not I have Resumed the game or if I go through the Start Game. I don't see anything that says Access Violation or anything, it just asks me if I want to report it to Microsoft, which I never do, what are they going to do with it? Not too much...

Shadow
12-13-2007, 08:39 AM
I would guess that 1.004 would fix these problems for you. Since from a different thread I know that you are playing the Reflexive version, you are going to have to wait a little bit before the patch is available.