PDA

View Full Version : Empty dungeon's on multiplayer


viper34j
02-12-2010, 01:45 AM
When playing multi player today with two friends, we noticed a strange issue. When I was up at town and they were both in the dungeon, occasionally the dungeon would be completely empty. But, once I spawned into the level enemies would appear.

Aganazer
02-12-2010, 09:28 AM
I wonder if this is related to the bug that happens when my wife (LAN client) would step on a pit trap and get teleported to an empty dungeon level.

Lyranaar
02-13-2010, 04:29 PM
We have in LAN games the same problem since 902. Up to 901 there was no problem.
Now if the host leaves the dungeon the monsters don't move for the client except if standing next to them, then they attack. It seems they don't see anything. On entering the dungeon by the host, the monsters get active again.

At least once when entering a new - until then unentered by the servering player - dungeon level, there was no monster there for the client.

Harkonis
02-14-2010, 03:08 AM
I had the same problems in an internet game.

jshar
02-16-2010, 04:24 AM
Yeah, i've found this too. Its related to where the host is. I find I get lag when the host is on any other floor and im not and sometimes when he goes back to town all the monsters stand still and unless you run RIGHT up to them if you try to attack it says "cant see". They're not "empty" they're just not spawned yet.

Good trick to get a few easy levels under your belt, anyway. I have a feeling the high levels of this game will get about zero testing before release.

Shadow
02-16-2010, 09:23 AM
I have solved an issue (and hopefully the only one) that causes this. The fix will show up in version 0.904.