PDA

View Full Version : Can't find the "evil artifact"


erbgor
03-19-2010, 03:17 PM
Hi,

bought the game a few days ago. All good so far, except I can't finish my first town - I have just one quest left: Din wants me to find an evil artifact at level 3. I've already been to the bottom of the dungeon, though. Now the thing is, i just can't find this goddamn artifact. Is it just supposed to be lying around? I searched the entire level several times.
Could it actually be at another level? Can it spawn in a secret area? Help please:)

Aganazer
03-19-2010, 04:08 PM
Can it spawn in a secret area?

Its probably in a secret area. Click any suspicious looking walls and you may find it.

erbgor
03-19-2010, 04:11 PM
Its probably in a secret area. Click any suspicious looking walls and you may find it.

I already tried that, no luck. Maybe I'm missing it - could someone spoil the pattern for me?

Thanks for the reply, though.

transigent8
03-19-2010, 04:53 PM
If it gets too frustrating just make a new town. The rewards when you're just starting out aren't great enough to beat yourself over not finishing because of a broken quest.

erbgor
03-19-2010, 05:03 PM
If it gets too frustrating just make a new town. The rewards when you're just starting out aren't great enough to beat yourself over not finishing because of a broken quest.

Yeah, I just checked - again, and I'm inclined to believe it's a bug. Guess I'll start over. Just wanted to have that sense of accomplishement, ya know. It being my first town and all :D

Shadow
03-19-2010, 05:31 PM
Hi,

bought the game a few days ago. All good so far, except I can't finish my first town - I have just one quest left: Din wants me to find an evil artifact at level 3. I've already been to the bottom of the dungeon, though. Now the thing is, i just can't find this goddamn artifact. Is it just supposed to be lying around? I searched the entire level several times.
Could it actually be at another level? Can it spawn in a secret area? Help please:)

It should be lying on the ground somewhere. It can't be on a different level. It can spawn in a secret area though.

erbgor
03-19-2010, 05:34 PM
It should be lying on the ground somewhere. It can't be on a different level. It can spawn in a secret area though.


Thanks for the reply. I've checked the entire level four times now, I tried re-entering through the main gate and restarting the game. Looks like a bug to me, not that big a deal as I can load a new world. Do you want the save files?


Edit: Also went along the walls all around clicking on them like a mad men. Pretty sure there's no secret area;)

Shadow
03-19-2010, 05:51 PM
Yes, post your save or email it to me and I'll see what's going on.

erbgor
03-19-2010, 06:04 PM
I uploaded as a zip, I hope I included everything needed.

trjp
03-21-2010, 08:08 PM
I have this same issue in the Demo version - the quest says Level 4 but I've searched it 3-4 times over and there's no sign of the artifact.

Copy of saves etc. attached if it helps!

PixelLord
03-22-2010, 01:15 AM
[QUOTE=trjp;12078]I have this same issue in the Demo version - the quest says Level 4 but I've searched it 3-4 times over and there's no sign of the artifact.QUOTE]

A couple of times I found the evil artifact behind a forward wall which made it hard to see as it was partially obscured; and it's pretty small too.

erbgor
03-22-2010, 09:21 AM
[QUOTE=trjp;12078]I have this same issue in the Demo version - the quest says Level 4 but I've searched it 3-4 times over and there's no sign of the artifact.QUOTE]

A couple of times I found the evil artifact behind a forward wall which made it hard to see as it was partially obscured; and it's pretty small too.


I use ALT all the time, routinely, so I don't think I could have missed it. Won't complain if someone proves me wrong ;)

trjp
03-22-2010, 11:16 AM
[QUOTE=trjp;12078]I have this same issue in the Demo version - the quest says Level 4 but I've searched it 3-4 times over and there's no sign of the artifact.QUOTE]

A couple of times I found the evil artifact behind a forward wall which made it hard to see as it was partially obscured; and it's pretty small too.

Even with loot-labels toggled on permanently?

PixelLord
03-22-2010, 12:11 PM
I use ALT all the time, routinely, so I don't think I could have missed it. Won't complain if someone proves me wrong ;)

I'm pretty sure that, like other items such as secret stash and lost hierloom, the evil artifact will not display a text tag with the alt key as it's intentionally meant to be more difficult to find.

That being said, your evil artifact may not be able to be found as there have been several reports of monster/item quests that could not be completed bwcause player could not find them. So, as someone else said, it might be better to move on to a new world than frustrate yourself any further. I know it makes me angry when I spend a lot of time trying to save a town and then can't for reasons that aren't my fault. So it may indeed be a bug. The game's beta, and beta is meant to shake the bugs out. :)

erbgor
03-22-2010, 12:29 PM
I'm pretty sure that, like other items such as secret stash and lost hierloom, the evil artifact will not display a text tag with the alt key as it's intentionally meant to be more difficult to find.

That being said, your evil artifact may not be able to be found as there have been several reports of monster/item quests that could not be completed bwcause player could not find them. So, as someone else said, it might be better to move on to a new world than frustrate yourself any further. I know it makes me angry when I spend a lot of time trying to save a town and then can't for reasons that aren't my fault. So it may indeed be a bug. The game's beta, and beta is meant to shake the bugs out. :)

Oh, I played several worlds since then :) I'm just curious. Plus I want to help squash bugs.

FloodSpectre
03-22-2010, 01:52 PM
I'm pretty sure the item label toggle shows evil artifacts. I swear I've seen it once, and it simply said "Artifact", not "Evil Artifact".

Heinosity
03-22-2010, 09:32 PM
I have this same problem in my current world. I have looked all over the dungeon at least 10 times. No secret walls, nothing laying around.

Shadow
03-23-2010, 09:50 AM
I have this same problem in my current world. I have looked all over the dungeon at least 10 times. No secret walls, nothing laying around.

I'm looking into this right now. Posting your save game would be helpful or email it to me. You can always start a new world with your same character to get around the issue.

Heinosity
03-23-2010, 01:44 PM
No problem Shadow, here is my savegame that has the problem...

Shadow
03-23-2010, 05:16 PM
I think I've tracked down the root cause of this now, so it should be fixed in version 0.911.

Heinosity
03-23-2010, 08:36 PM
Very nice. Keep up the good work! :D

Markoff Chaney
03-23-2010, 08:43 PM
Fantastic! I hit this same bug earlier today. Thanks for all the hard work at polishing this gem for us.

erbgor
03-24-2010, 12:28 PM
I think I've tracked down the root cause of this now, so it should be fixed in version 0.911.

Glad to hear.

PixelLord
03-30-2010, 07:57 PM
I'm pretty sure the item label toggle shows evil artifacts. I swear I've seen it once, and it simply said "Artifact", not "Evil Artifact".

You are, of course, correct. I finally had the evil artifact quest come up again, and it did indeed have the text tag "artifact". Sorry for the misinformation earlier.