PDA

View Full Version : Crash when creating new town


kallisti_dk
03-20-2010, 01:20 PM
Let me first say that this is a very enjoyable game, and I'm glad I bought it, even as a beta.

But here's the problem. I'm getting a crash now with my character after after choosing the parameters for the new town. I attached the save.

I clicked the crown icon while at the bottom of the dungeon. Maybe that created the issue.

I had the same issue earlier and i fixed it by choosing "Create new world" from the main menu. The game worked fine then. It still counted the town as completed, but scored one abandoned town against me.

Shadow
03-22-2010, 11:38 AM
I'll look at it.

Shadow
03-24-2010, 01:05 PM
This will be fixed in version 0.911. Thank you very much for the save btw. This is one of those issues that would have been a huge pain to track down and might have already been reported a few times. Having a save though made it easy.

Here's what actually happened: Your character was on level 12 when you transitioned over to the new town. For a brief moment you are added to the new town's level 12 entity list. Except most town's don't have a level 12, so what really is going to happen most likely is an array out of bounds issue.

kallisti_dk
03-24-2010, 02:44 PM
Glad to be of service.