PDA

View Full Version : Drox Operative on a 2010 MacBook Air


rampancy
12-25-2012, 04:59 PM
I've been trying my hand at playing Drox Operative on my 2010 11.6" MacBook Air with a GeForce 320M...and a 1.4 Ghz Core 2 Duo. I've just realized that the minimum requirements call for a 1.5 Ghz CPU, but the GPU should make up for the 100 MHz shortfall, right?

Right now, the game works reasonably well, but during medium-sized fights (and larger) the game slows down considerably, even with all of the graphical effects disabled and filtering set to none. It leaves the game borderline unplayable. Are there any other possible things I could do to improve performance with the game on this computer?

Shadow
12-27-2012, 02:51 PM
Our games are mostly cpu limited. There are a bunch of graphics options that you could try to turn off or set lower that might help. Try the fastest setting option and tweak from there.

spacehog
12-27-2012, 03:06 PM
I can't offer much help, but I run Drox Op on a similar model Macbook and it runs very smoothly on the highest graphics settings. There was one patch not too long ago where the game barely ran at all, but the latest patch runs very smoothly. If you haven't already downloaded it, I would try the latest patch.

rampancy
01-03-2013, 01:26 PM
I can't offer much help, but I run Drox Op on a similar model Macbook and it runs very smoothly on the highest graphics settings. There was one patch not too long ago where the game barely ran at all, but the latest patch runs very smoothly. If you haven't already downloaded it, I would try the latest patch.

I'm right now running the latest retail version, which is 1.000, as far as I know. I've tried just about everything, with pretty much no improvements seen.

I'm not really all that upset, but just oddly bemused that a game that can run pretty well on a Core Duo MacBook with a lowly GMA 950 can be practically unplayable on a much more modern MacBook Air,

Bluddy
01-03-2013, 01:57 PM
This is a well known issue with the game engine on OSX Lion and above.

The only known solution is to disable sound:
1. Press ~
2. Type setUserVar s_initSound 0
3. Restart the game

You should now have much better performance.

Shadow
01-03-2013, 04:51 PM
I'm hoping to start debugging that issue fairly soon. I finally got my Mac upgraded to the latest version of OS X.