PDA

View Full Version : DC Hangs at title screen


Draugr
04-21-2010, 07:33 PM
This started the other day. I think it was the same day I installed the game.

I tried uninstalling and then reinstalling the game.

When the main title screen comes up the program freezes. Now, If I go into the Local Settings \ Dins Curse folder and move out all of the files from within that folder the game starts as normal and I can create a new character then enter the game and save it. I then place back my original character file and my character is back although with a new world. This has happened everytime. When I exit the game I save and then exit it through the proper methods. I don't just Cntrl-F4 it or just turn off the PC.

Does anyone else have these problems? It looks like its one of the data files in hte save directory. Again, I removed them all and the game worked fine. I then put my character.chr file back after I create a new character of the same name and start/save a new world. This works until I save, exit and then go back. The game then hangs again.

Anyone else have this problem?

Thanks
John

Draugr
04-21-2010, 07:37 PM
Ok, this is weird. I just tried to do the fix I mentioned above but the game is still freezing at the title screen. I even tried to remove the entire DinsCurse folder, but that didn't help. So, it seems the problem I'm having is with the game itself and not actually the save files.

Valgor
04-22-2010, 08:18 AM
I'm occasionally experiencing freezes at the title screen as well; the game just hangs and I have to call up the task manager to shut it down.
It's not a major issue to me, since the game works perfectly fine otherwise... it can get mildly annoying when it happens two or more times in a row, but like legendary items, this is extremely rare.
This has been going on since the initial beta version (0.900), in fact, it's a problem I've had with Soldak's games since the early versions of Depths of Peril...
but as I said, most of the time it starts up just fine, so this doesn't spoil the game for me at all.

I wonder what it could be, though...

Draugr
04-22-2010, 08:51 AM
For me it seems to be happening more times than not.

Also, it seems if I can time it right and click on the resume or play game button immediately after the title screen comes up I may get into the game without a problem. If I miss or hesitate even for a second the game will lock up requiring Task Manager to kill the process.

TheRani
04-22-2010, 06:56 PM
The only time Din's Curse ever crashes for me is once in a while, usually right after creating a new character, it will crash when generating the first town. I've never had it die at the title screen though.

Caal
04-22-2010, 07:16 PM
I've had an issue with character creation. If I play one character for a while, then create a new one, as soon as the new character is created, the screen goes black, requiring a program manager exit. On restating, the new character can be created without issues. So now I just have to remember that if I want a new character, do that first.

Shadow
04-26-2010, 02:21 PM
For the OP, all I can think of is to upgrade your graphics and sound drivers. I can't think of anything that would cause issues on the opening menu itself.