PDA

View Full Version : Warp gate activation missing in multiplayer


droxop55
12-29-2012, 06:03 PM
When I rejoin a multiplayer game as a client to the server, all of the warp gates that I had activated are lost. However, when I go to the galaxy map, I can see all of the solar systems I've been to in that game, so it knows I have been to those systems before as a client.

If that is intended, I'd like a way for the host to share all of the jump gates that s/he has activated, so that I don't have to fly around and reactivate them, especially if I logged out in a hostile galaxy.

droxop55
01-01-2013, 05:43 AM
When I rejoin a multiplayer game as a client to the server, all of the warp gates that I had activated are lost. However, when I go to the galaxy map, I can see all of the solar systems I've been to in that game, so it knows I have been to those systems before as a client.

If that is intended, I'd like a way for the host to share all of the jump gates that s/he has activated, so that I don't have to fly around and reactivate them, especially if I logged out in a hostile galaxy.

Upon further investigation, it looks like the jump gates *are* remembered by the client. However, when I go to a jump gate and look at the galaxy map, all of the galaxies that I had been to before logging off and rejoining are considered uninhabited, thus the warp gate is not available because it is an uninhibited solar system in my game.

But, the host of the game shows the sector properly on his screen, the solar systems being inhabited and his warp gates work without an issue.

Perhaps the inhabited solar systems are not being sent to the client upon reconnect?

Shadow
01-08-2013, 01:09 PM
They should be getting sent, but they might not be guaranteed. If that is the case and the packet gets lost you would have problems. I'll look at it.