PDA

View Full Version : Bug...? Incorrect responses to Left Clicks?


Tyrax Lightning
02-25-2013, 03:43 PM
I have the Drive by Mouse option off, & now use a Hellfire Weapon in Hotslot 1 to Left Click Enemies with it. If I attempt to Left Click Hellfire Enemies after Left Clicking a explored ordinary Planet, it won't activate the Hellfire or select the Enemy in the process, instead the Planet stays selected & the game force-drives you to the Planet if you're not already on top of it.... the game won't quit driving you back to that Planet if ya try to fly away from it... & if ya try to left click Hellfire an enemy while the Planet is still 'locked on', the game won't switch the lock on to the enemy & attack with the Hellfire, instead, it drives you back to that Planet if you're not already on top of it... & if ya are already on top of it, then the Left Click Hellfire just does nothing. This also seems to apply to Friendly Race Planets somewhat... if ya Left Click a Friendly Race Planet, like to Trade with them, during the time that Planet is selected, ya can Left Click attempt to Hellfire an enemy, like one attacking that Race Planet, & it does nothing instead of switching the Lock On to the enemy & firing on them. The force-drive back to the planet thing does not seem to happen on Friendly Race Planets though, maybe because it DOES have an Interaction that can be done with them, unlike ordinary empty Planets.

I hope I managed to explain this clearly enough... but in short, it seems like there's an Interface Bug that is causing the Left Click to not correctly switch 'Lock On', then react to it appropriately in some cases.

Oh, before I forget, this is extra aggravating in the case of accidentally clicking a ordinary Planet with nothing else around it at all, & having the game trap you on that Planet with this bug... the only way I can free myself is to select one of my Fighters to switch the Lock On to it, then I cannot deselect the Fighter until I find something clickable other than the Fighter, like something to pick up, a Ancient Recharge Station, etc. & during this time, I can't count on being able to Hellfire an Enemy by Left Click. :(

I've had a couple of times where I blew up an Enemy Race Planet, click picked up the Loot, then accidentally clicked the Planet afterwards, & had this Bug trap me onto that Planet with my Fighters dead & not available to Click on, thus permanently trapping me on the Planet helplessly unable to Kite or Escape & at the (lack of) mercy of the remaining enemy Ships... unable to prevent my own destruction... :mad:

If i'm right about this being a Bug, please fix! if i'm wrong about this being a Bug, please tweak it anyway! :(

yoyodelta
03-02-2013, 05:57 PM
I experience this same bug quite often as well. I cannot give an exact description of when it occurs, but here is a common situation:
==========
At a race planet, trading or otherwise have the planet menu open. An enemy ship approaches, I attempt to click on them to attack them. Instead, my focus is redirected to the race planet, and it brings up the planet menu again. If I first attempt to fly away from the planet some and then attack, my focus is still diverted back to the planet, and it drives me back to the planet. Re-clicking elsewhere in space doesn't seem to break the auto-pilot well.

If I repeatedly click the enemy quickly while in range, after a few tries it will attack and focus on the planet is broken.
==========

I have a prediction that this happens more often when the enemy I try to target is initially out of range.

I've experienced this bug during 1.002 and 1.004 patches (did not sue 1.003), I don't recall if I experienced it before then. Please find a fix for this! It's the only bug I've noticed that's causing me problems.

Tyrax Lightning
03-03-2013, 04:16 PM
I experience this same bug quite often as well. I cannot give an exact description of when it occurs, but here is a common situation:
==========
At a race planet, trading or otherwise have the planet menu open. An enemy ship approaches, I attempt to click on them to attack them. Instead, my focus is redirected to the race planet, and it brings up the planet menu again. If I first attempt to fly away from the planet some and then attack, my focus is still diverted back to the planet, and it drives me back to the planet. Re-clicking elsewhere in space doesn't seem to break the auto-pilot well.

If I repeatedly click the enemy quickly while in range, after a few tries it will attack and focus on the planet is broken.
==========

I have a prediction that this happens more often when the enemy I try to target is initially out of range.

I've experienced this bug during 1.002 and 1.004 patches (did not sue 1.003), I don't recall if I experienced it before then. Please find a fix for this! It's the only bug I've noticed that's causing me problems.
Yes, this sounds like what I experience as well, though I never tried rapid fire clicking a Monster while Trading at a Race Planet before. This is VERY problematic for usage of Targeted Attacks in Hotslot 1 via Left Click, like the Hellfire, Missiles, etc. Even worse if I cannot redirect the Target off the Planet or other such object via the 'Target Nearest Enemy' Hotkey, clicking & selecting a Fighter, etc... though even Selecting a Fighter only enables ya to drive away from a Planet at last, but ya can still have problems with being able to attack the actual Monster till ya can either 'Target Nearest Enemy' Hotkey or Interact with something that disappears after Interaction while self-clearing the Target afterwards, like for example, picking up a Loot Item. :(