PDA

View Full Version : Monster joining group breaks quest?


Valgor
06-29-2010, 12:32 PM
I just ran into this peculiar bug :

While I was on my way to kill Corpseripper's group, a legendary spider by the name of Toxic joined said group.
This somehow caused the quest to solve itself without me doing any of the required killing. When trying to cash in at the Warmaster's, the reward was only a fraction of the XP I should have received and the quest was not removed from the log. Now, everytime I speak to the Warmaster, he offers me to solve the "Kill Corpseripper's group" quest, and if I agree, the Quest Solved! jingle plays,
but nothing actually happens. This means I'm stuck, since it leaves all the Warmaster's other mandatory quests unsolvable.

Shadow
06-30-2010, 10:06 AM
That's strange, I'll look at it.

random_rolle
06-30-2010, 06:30 PM
I've had that bug, the thing is, the quest isnt really solved, game only thinks so. If you go down to the level where quest were, and kill all the unique monsters you can then turn it in normally and continue with other quests.

Valgor
07-01-2010, 08:22 AM
Well, I went back and tried to do that, but upon resuming the game in question, the quest was gone entirely.

Bomphav
07-29-2010, 03:57 PM
I had the same thing happen to me; a duo of monsters became a trio. I was able to solve any warmaster quests that I had completed, but I couldn't talk to him or see the new quests. After killing the trio of monsters, I could successfully solve the quest, and things went back to normal.

This was on the Mac version, did it happen on PC too?

Shadow
07-29-2010, 06:52 PM
Bomphav: Was that with a recent patched game? I hopefully fixes this issue in version 1.003 I believe.

Bomphav
07-30-2010, 03:21 AM
I was running version 1.002, on a Mac, downloaded about 10 days ago.