PDA

View Full Version : Are we sure the stealth cloaks are working?


Tuidjy
07-13-2013, 11:53 PM
I remember two recent posts from other people saying that stealth cloaks are worthless. I started a stealth ship recently, and I have been quite happy with it, but the extension pack came out at pretty much the same time, so maybe it appears very good mostly because the extension pack has all these new shiny toys.

What makes me think that they may be something wrong with cloaking? Take a look at this screenshot. It shows my recently uncloaked ship, supposedly benefiting from a 460% attack bonus, missing six times against a target that has been supposedly debuffed for 1040 defense. OK, the target is 13 levels higher, but I assure you, I'm used to my ships taking on targets 25 levels higher and not missing more than once in twenty shots.

http://i.imgur.com/36cFwh7.jpg

And here is two more pictures showing my ship missing a ton of shots, against ships that have been affected by a virus weapon. I do not know what's wrong, whether it's the cloak, or whether my ship's attack has rolled over, or whether the Legion and the Overlords ships sometimes get insane defense, but whatever it is, I think it is worth looking into.

http://i.imgur.com/qSCjC7M.jpg

http://i.imgur.com/8KRkiJK.jpg

Tyrax Lightning
07-14-2013, 02:06 PM
I remember two recent posts from other people saying that stealth cloaks are worthless. I started a stealth ship recently, and I have been quite happy with it, but the extension pack came out at pretty much the same time, so maybe it appears very good mostly because the extension pack has all these new shiny toys.

What makes me think that they may be something wrong with cloaking? Take a look at this screenshot. It shows my recently uncloaked ship, supposedly benefiting from a 460% attack bonus, missing six times against a target that has been supposedly debuffed for 1040 defense. OK, the target is 13 levels higher, but I assure you, I'm used to my ships taking on targets 25 levels higher and not missing more than once in twenty shots.

*Snip*

And here is two more pictures showing my ship missing a ton of shots, against ships that have been affected by a virus weapon. I do not know what's wrong, whether it's the cloak, or whether my ship's attack has rolled over, or whether the Legion and the Overlords ships sometimes get insane defense, but whatever it is, I think it is worth looking into.

*Snip*

*Snip*
Ya forgot to Screenie your Components, & Stats, including displayed Attack Stat. ;)

Tuidjy
07-14-2013, 02:41 PM
Ya forgot to Screenie your Components, & Stats, including displayed Attack Stat. ;)

I did not because that ship is no different, for its level, from my normal ships. It's five levels higher now, but its hit chance against ships of its level is 96%. Here's a screenshop how it usually does damage. Notice that the cloak was not engaged before I attacked.

http://i.imgur.com/m09wD19.jpg

Tyrax Lightning
07-15-2013, 01:33 PM
Ahh, & I thought Cloak was Underpowered before... :/