PDA

View Full Version : Crash approaching starlane to quest-filled system


Laivasse
08-18-2013, 10:42 PM
My game locked up and crashed twice when approaching a certain starlane. I waited and tried again a few minutes later without crashing, but I noticed that the system in question has an extremely long list of quests associated with it. I'm speculating that this might be the cause of the crash.

Screenshot. (http://cloud-4.steampowered.com/ugc/612774732094164730/39FB58DC6AF33B2279D95CE6A5DD6FA9E3911C4D/)

Windows error message from the second crash:
Description:
A problem caused this program to stop interacting with Windows.

Problem signature:
Problem Event Name: AppHangB1
Application Name: DroxOperative.exe
Application Version: 0.0.0.0
Application Timestamp: 520e672a
Hang Signature: d08f
Hang Type: 0
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 2057
Additional Hang Signature 1: d08fb5acb35936ae5db4dd34083b0643
Additional Hang Signature 2: e776
Additional Hang Signature 3: e776b295ab4d1f562bbf9a5fee05779b
Additional Hang Signature 4: d08f
Additional Hang Signature 5: d08fb5acb35936ae5db4dd34083b0643
Additional Hang Signature 6: e776
Additional Hang Signature 7: e776b295ab4d1f562bbf9a5fee05779b

Laivasse
08-19-2013, 01:58 AM
This system caused the game to crash once more, this time from the sector map. Mousing over the system seems to give an immediate lock up, probably due to the long quests list. I must have just got lucky the time I was taking the screenshot.

Tested this out some more and it's quite unpredictable. Got no crash the first few times I tried mousing over the starlane or the system via the map. Kept playing and testing every minute or so and pretty quickly got the crash, from the system mouse-over in the map again.

Playing with v1.019.

Shadow
08-19-2013, 12:53 PM
Do you have a save game you could send me?

Laivasse
08-19-2013, 01:44 PM
I sent you a download link in PM.

Tuidjy
08-19-2013, 04:49 PM
I experienced the bug myself. I reloaded, flew straight to the system that was full of quests, and cleared most of them. No problems since.

Shadow
08-19-2013, 06:49 PM
I believe I have this fixed now in 1.020.