PDA

View Full Version : Performance Issues in OS X 10.9


miwhetep
10-23-2013, 11:27 PM
I just updated my MacBook Pro to Mavericks today, and there is definitely a decrease in graphics performance in Drox Operative with Rise of the Ancients. All of the graphics settings in the game are the same, but gameplay is not as smooth and tends to feel jumpy. Has anyone else run into this issue? I'm running a MacBook Pro 10,1.

Scott

miwhetep
10-24-2013, 12:51 PM
Just to follow up, it looks like the issue isn't specifically with Drox. I ran NovaBench and compared my results to when I was running OS X 10.8.4. The benchmark dropped to 1149 from 1173 after installing OS X 10.9. I hope an update comes out later to fix this!

Scott

Bluddy
10-24-2013, 11:41 PM
What MBP do you have? Year and screen size?

ScrObot
10-25-2013, 12:43 AM
Purely FYI I've been seeing reports of other games having issues with Mavericks as well.

miwhetep
10-26-2013, 12:09 AM
Bluddy,
It is a Mid-2012
15" Retina Display
2.3 GHz i7
8 GB RAM
256 GB SSD
Auto graphics switching between
Intel HD Graphics 4000 1024 MB and
NVIDIA GeForce GT 650M 1GB

I disabled auto graphics switching, thinking Drox was using Intel graphics, but it made no difference.

Scott

Bluddy
10-28-2013, 12:53 PM
Bluddy,
It is a Mid-2012
15" Retina Display
2.3 GHz i7
8 GB RAM
256 GB SSD
Auto graphics switching between
Intel HD Graphics 4000 1024 MB and
NVIDIA GeForce GT 650M 1GB

I disabled auto graphics switching, thinking Drox was using Intel graphics, but it made no difference.

Scott

Are you using gfxCardStatus to make sure the NVIDIA card is working? You really should. You should use gfxCardStatus anyway to improve your battery life and to prevent a GPU overheating issue that seems to be plaguing MBPs. I just had to have my MBP's logic board replaced because of this issue.

miwhetep
10-28-2013, 10:09 PM
Thanks Bluddy! I noticed that when I play Drox, the laptop gets really hot. I'm glad you told me before it burned something out. After installing gfxCardStatus and putting the graphics on discrete only, my NovaBench score went back to what it was before I upgraded to 10.9. Apparently, the box in the power settings on the Mac stopping graphics switching does not work. Unfortunately, the graphics in Drox are still not as smooth. It isn't really that bad, but it is noticeable compared to what it was in 10.8.4.

Scott

Bluddy
10-28-2013, 11:16 PM
Try to disable audio in the game and see if your performance improves. In ~/Library/Application\ Support/DroxOperative/User/user.cfg, set s_initSound to 0. There used to be an easier way to do this from within the game, but I think the console is disabled now.

Shadow
10-29-2013, 11:48 AM
There used to be an easier way to do this from within the game, but I think the console is disabled now.

The console defaults to off now, but there is a check mark in the options to allow the console.

zIpPeDy
04-18-2014, 07:30 PM
Are you using gfxCardStatus to make sure the NVIDIA card is working? You really should. You should use gfxCardStatus anyway to improve your battery life and to prevent a GPU overheating issue that seems to be plaguing MBPs. I just had to have my MBP's logic board replaced because of this issue.

Thank-you, Thank-you, Thank-you Bluddy!
My game had stopped working a few months ago, when I bought a new (to me) MacBook Pro (15-inch, mid 2012, 2.3 GHz i7). I suspected that it might be a Graphics Issue because the opening screen of the game would appear (though none of the buttons worked, despite the working animation) but the graphics were kinda like an Impressionist painting, yet I couldn't figure out how to fix it. I searched this Forum for "Mac" and other useless search terms, then searched the Web, then moved on to try other games to get my 'fix', but today I decided to try yet again and found your suggestion (this time I searched for "MacBook") and VOILA!
What I don't understand, is why my Mac does not AUTOMATICALLY switch Graphics Cards (though I wil admit, I'm somewhat lazy and have never read up on this aspect of my computer - and so just assumed that switching would occur as needed). Anyway, Thanks again for the info, (and I will be returning to the gfxCardStatus web site momentarily, to donate something for the developer's efforts, for this wonderful quick fix!