PDA

View Full Version : PC freeze deletes game settings and corrupts character/ship data.


Marikhen
02-25-2014, 08:39 PM
Just had my PC lock up on me while playing Drox Operative and in addition to deleting/corrupting my current character the config data was also lost. I had to reset graphics options and control changes.

Trying to load up my now "level 0" ship in its old sector crashed the game, and in a new sector it has, IIRC, no slots, crew, gear, or attributes. Oh, yes, it's name is now -0 or 0 in the new sector (was named Beatrice so that's a bit off the mark), hostile NPCs ignore it, and bombs don't damage it. Things get even more odd on save & exit. Reloading that save results in the fog of war being reset, experience being set to 0, help messages popping up again despite being disabled, and yet explored planets are still explored and dropped loot is still floating in space.

All in all it's rather interesting, but not worth the cost of losing the ship I was having fun playing around with or the nicer components and crew members it had on it.

Just noticed something even more annoying than losing the ship, I lost the shared stash as well.

Shadow
02-26-2014, 02:01 PM
The game doesn't load or save all of those things at once. I would really run some diagnostics on your hard drive to make sure everything is ok.

Marikhen
03-16-2014, 10:02 PM
And I just had a repeat of this. The last time I had my CPU overclocked in what had been a stable configuration. I reset everything to default a couple of days ago so I know it's not crashing due to an unstable OC.

Thankfully this time I'd just gotten done backing up my DroxOperative\User folder so all I lost was some pissing around in a level 0 sector with a level 18 ship to see what I could break.


The game doesn't load or save all of those things at once. I would really run some diagnostics on your hard drive to make sure everything is ok.

I've got things spread across three drives. My OS is on one partition of one drive, my games all go to a second drive, and my Users profiles are all on a third drive. The first two are relatively new 1TB drives while the other is an older 120GB drive. The 120GB drive, the one where the DroxOperative\User folder for this game is stored, tested fine with a couple different checks and programs.

In all honesty I've seen similar issues with World of Warcraft and EVE Online on both my current and previous machine and with user profiles stored on a minimum of 4 different hard drives across multiple OS (re)installations including, at various points, the two 1TB drives I mentioned earlier. Those issues being config files lost/corrupted due to the game freezing/crashing or my PC freezing or BSOD'ing on me. I won't categorically deny that it could be the drive in this case, but I strongly doubt that it's the problem.