PDA

View Full Version : Who done it?


DeathKnight1728
01-01-2011, 12:35 AM
I've gotten to the point where im starting to get many quests where someone in town has screwed me over. They first poisoned the water supply and i had to find the person that did it. They said to look for the evidence papers but i looked in everyone's house and couldnt find it so i failed. Now its getting worse, the bastard's poisoned the food supply. This has to end here because i have no idea whats next. Has anyone solved this yet cause i cant just fight anyone who's happiness is -, or can I?

EternalChampion
01-01-2011, 01:25 AM
I haven't solved one of these yet, but after I failed a similar quest, I found the papers (too late) laying out in the open between 2 buildings. :mad:

This learning curve sucks. :D

icecube
01-01-2011, 01:46 AM
Ah, I just got my first ones 10-15 minutes ago.

I had read about the papers on the forums so I went looking for them. Found two evidence papers outside the same guys house; apparently he stole twice. But I didn't know what to do. I noticed we had the option to fight people so I killed him. Well, I failed that one.

Tar Palantir
01-01-2011, 04:55 AM
I got a few of those quests and managed to solve them, but imo it can be more difficult than the standard quests.

the so called papers look like the death notes or treasure maps and can sometime be in the corner of a house or some other well hidden place.

DeathKnight1728
01-01-2011, 10:55 AM
Did it say who you give them too because i cant figure that out. There wasnt a green exclamation point mark above anyones head.

joku
01-01-2011, 12:10 PM
I believe you give them to the Steward.

If you take too long in finding the evidence, then the person who committed the crime will destroy it and you will fail the quest. But when the evidence is "destroyed" it isn't actually removed from the map, so you can still find it and pick it up.

So if you picked up evidence, but can't turn it in to the Steward, then you may just taken too long and didn't notice.

Shadow
01-01-2011, 12:41 PM
But when the evidence is "destroyed" it isn't actually removed from the map, so you can still find it and pick it up.

That would be a bug.

DeathKnight1728
01-01-2011, 01:26 PM
i just searched through the whole town 3 times and its not there. Im not sure if it recognized that it wasnt there from the previous quest or if it is off the map.

DeathKnight1728
01-01-2011, 07:58 PM
Found out whats wrong. Its not supposed to show up as the text, you have to look for it and find the paper manually. I was wondering why it didnt show up, since im too lazy to find it the hard way :D