PDA

View Full Version : Can't finish the quest


Doom314
12-16-2007, 03:40 PM
I'm on the storyline quest where I need to kill 13 death knights.

I've completed it before with other characters.

This time, I kill 10 knights and it says I have 3 more to go.

But, no matter how many death knights I kill (I'm in the same area as the previous 10), they don't register. I tried saving out and coming back, no dice. I've tried dismissing the henchman and killing them solo, no dice.

Any other suggestions?

Shadow
12-16-2007, 04:50 PM
That's really strange. I haven't seen that before. You could decline the quest and get it again and see if you can solve it then. It might reset you back to 0 killed though.

At worst you could start a new game with that character and then skip all of the story quests up to that one again.

Doom314
12-16-2007, 09:30 PM
Problem solved, quitting/restarting worked. I didn't wanna do that right off, since it might erase the bug, but, the solution does work. ;)

Thanks!

Ratatwisker
12-17-2007, 09:35 AM
I had the same problem with another quest. There were 2 quests where I should kill sentries, but in different location (different levels of a subdungeon). The first one went fine, but at the second I'm stuck with the last sentry left to kill. Maybe this can happen if I kill two sentries at the same time? I don't know, at the moment where I should have completed the quest, it was really vrowded around me, so I had no overview.

[Edit]
It seems they doesn't get counted, so it's not a mix-up with the counted number itself. I was able to "solve" the quest via hexeditor.

Shadow
12-17-2007, 12:26 PM
I forgot to mention that I'll look into this.

CautiousChaos
12-26-2007, 04:39 AM
I forgot to mention that I'll look into this.

Hey Shadow,
I'm seeing the same thing. I was questing to rid 14 baddies and closed down Depths of Peril when I had 10 out of 14. Came back and I wasn't able to increment the counter no matter how many of the baddies I killed off in the quest area.

cc

p3n4nc3
12-26-2007, 05:48 PM
CautionsChaos....that has happened to me a few times with "counter" quests. What I've done is delete the quest and start over :/ I haven't found any way to unlock it when it gets frozen like that. It has never happened w/ collection quests, only with "kill count" quests 'bout 3x.

Shadow
12-27-2007, 11:20 AM
I'm going to look at it. Maybe it's saving and exiting in the middle of the quest that breaks it somehow.

Shadow
01-02-2008, 03:09 PM
I still haven't been able to reproduce this. If anyone could send me a save game of a broken kill X monsters quest it would probably be a lot easier to track down. I did change one small thing, but I don't know if it fixed the problem or not.

Ratatwisker
01-05-2008, 08:43 AM
Could be I still have a savegame where such a quest is broken. I'll take a look at it within the next few days - where shall I send it to?

Shadow
01-05-2008, 10:43 AM
That would be great. Send it to me. You can find my address on our contact page (http://www.soldak.com/Company/Contact.html).

SuperSayu
01-19-2008, 08:40 PM
Hi, I'm new, posted only once before. I got this bug too, and have sent a copy of what I believe to be all the affected savegame files to the support address on the contact page, along with a few details. I would have checked here to see if you still needed it, but I figured it's easy enough to delete an email if you don't need it, and I intend to continue playing for now instead of just sitting on the files as they are.

Shadow
01-20-2008, 10:32 AM
I haven't had a chance to look at them yet, but I did get the files in your email. I did still need a good example of this broken, so hopefully the save game will be useful.

Areli
01-20-2008, 02:35 PM
Just want to add that I've had this problem as well. Kill a dozen or so of the required monster; then left with a few to go that are not registering.

Areli
01-21-2008, 07:21 AM
I had this error happen again recently and have a hypothesis as to what the problem could be.

Part way through the quest, I gained a level. Perhaps this causes the quest to stop registering the kills. I wasn't keeping exact track of how many Death Knights I had left, but now I'm stuck again with 3 to go.

I sent you an email, Steve. Also wanted to post this theory here so others can try it if possible since additional levels for my Rogue are few and far between.

Delve
01-21-2008, 10:10 AM
I know this has happened to me without the level gain. Next time it happens I'll try to remember to send in my savegame.

(name here)
01-21-2008, 02:49 PM
I've seen this. it said in the quest window that i was supposed to kill ten, but the stuff that flashed onscreen counted to 13, but froze at 10

Shadow
01-22-2008, 09:12 AM
I do have 2 different save games for this now, so hopefully I will be able to track this down.

Shadow
02-01-2008, 04:44 PM
Ok, thanks to the save games from SuperSayu and Areli I was able to track down the problem. It should be fixed in version 1.008.