PDA

View Full Version : Multiplayer connectivity problems (black screen), 0.921


Forevener
02-21-2016, 03:13 AM
My friend is still unable to join my multiplayer game, he gets black screen after receiving a message "Successfully joined".

1. I can visit his town, see his character and check his equipment. His town looks a bit strange (http://images.akamai.steamusercontent.com/ugc/316746134560664605/99480F713080069E700A4F335345F66BC7BB7752/), though (lamps are too bright).

2. Everything else works fine, my ports are open, other Soldak's games work too in multiplayer.

3. I can connect to him with no problems. We both running Windows 10.

4. I tried disabling Windows Firewall, it changed nothing. Also enabled DMZ on my router, still no luck.

Shadow
02-22-2016, 10:13 AM
Well he could help debug the problem by doing the following:
1) Turn on the console in the game options
2) Open the console with ~
3) Type in the following 2 lines into the console and hitting enter at the end of each command
4) n_printMessageNames 1
5) n_printFragments 1
6) Shut the console again with ~
7) Try to connect to your game as usual
8) Send me the log file that should contain message names and fragment data of what happened.

Forevener
02-23-2016, 12:31 PM
I've saved logs from both computers.

Shadow
02-23-2016, 01:30 PM
Ok, thanks to those logs I think I know what is going wrong. I made the networking layer smarter about how long to delay fragments, so hopefully this will work better in 0.922.

Forevener
02-26-2016, 01:54 PM
It seems 0.922 solved this issue. Thanks!