PDA

View Full Version : Trying to modify NoStash variable in Crew.gdb


Guardfather
02-22-2018, 11:33 PM
Downloaded a mod called CrewStash which is supposed to let you put crew into stashes. It wasn't working. I tried debugging, but I'm kind of bewildered.

Now, I notice the "NoStash" variable is present in the Crew.gdb files in both assets001 and assets003. I'm guessing the crewstash mod should override both of those, but I'm wondering if there's some problem with that.

I've tried:
- Changing the line "Crew overrides BaseCrew" to just "BaseCrew"
- Moving the file from the Database directory to the Database/Items directory (to match the structure of the assets00x files)
- Copying the entire Crew.gdb file from assets001 to the mod folder and changing the NoStash variable from 1 to 0
- Combinations of the above.

Nothing seems to work. I cannot put crew into my stash. Any ideas?


update:
I've tried extracting the folders from a working mod, copying them into a folder with a different name, compressing that folder into a zip file, and using that instead. Despite having the same files in it, the new zip file does not work. I'm REALLY bewildered now. I'm thinking of looking into using a different zip utility, checking file permissions, etc. Really eager for any insight.

update2:
Took a working mod zip file, extracted the files, zipped them again, this time with the same names everywhere. The file did not work. A renamed copy of the original working mod did work. So I'm thinking there's a problem with the zip file headers or something.
I'm using Gnome 3's default file manager "right click > compress" option to zip the files. I'll be experimenting further.

update3:
I sent one of the zip files I created with files from a known, working zip file to a friend who uses Windows. He extracted the files, and then zipped them up again. The file size was different, but the file indeed failed to work with the game again. So I'm now thinking these files must be created by the SDK somehow. Which is Windows-only. And I don't use Windows. @#$%

update4:
Friend took a working copy, extracted that, rezipped it, and that worked. I unzipped that, rezipped it, and that failed again. So it seems there's some issue with the zip compression or decompression, or both, in Debian.


FINAL UPDATE (probably):
If I start with a valid zip archive that works, I'm able to use the File Roller utility in Debian/Gnome3 to update the zip file with additional files, and alter existing files. Doing this, I was able to get the crew stash mod working by inserting it into the ZMODbags zip file. I did have to alter the version I downloaded, and copy the crew.gdb from assets003, then alter the NoStash parameter. But it works. I can now put crew into stash.

Being that this is tedious and ridiculous to have to do repeatedly, I'm still VERY eager for a solid fix.

Shadow
02-23-2018, 05:34 PM
I'm not sure this is your issue, but the biggest gotcha is usually not zipping up the correct directory. Like gdb files need to be in the Database directory. So if you just zipped up Mod_something.gdb into a zip file nothing would happen, but if you put it into a Database directory and then zipped up the directory, it would work.

Also, things in assets003 override what is in assets001, so you should always start with things from assets003 (if it is in there).

Guardfather
02-23-2018, 10:17 PM
I had the directory structure correct. There's some issue with it not recognizing zips that come from my machine, or some reason. I wasn't absolutely sure until I had a friend zip up the files (with correct directory structure) and send that to me (it worked with the game), then tried extracting the files, and rezipping them with the same directory structure on my machine. The mods no longer worked.

Does the game use some odd zip library or something? I've never had an issue with zip file compatibility like this before.

Shadow
02-24-2018, 01:58 PM
It just uses the zlib library. You could email me your zipped mod that doesn't work and I could probably see where it fails.

Evander
08-12-2019, 06:30 PM
Use 7-zip.

Backup whole assets003 file before modding.

Remove NoStash line instead of setting it to 0, save file, replace in zipped file.

Ah the pain of not using Windows ;)