PDA

View Full Version : DC Demo crash at launch + fix (Windows 7)


Sarkazein
06-10-2011, 12:54 PM
Heya,

I've been looking at getting DC recently, and I've been trying to decide which platform to get it on (I'm a Mac/Windows guy). The performance is a little low on my MacBookPro, so I thought I'd try it on my gaming PC. However, the demo crashes immediately once it gets to the main menu.

Looking around in some other threads, it seems like there's a compatibility issue with the ATI drivers. The demo wasn't even writing a user.cfg, and the log was empty, but I read about creating a user.cfg and adding the logging command to it. That gave me a log that would get all the way to "Debugging Initialized" or something like that.

I also read about trying to upgrade the OpenAL drivers, but that didn't help (even copying the newer DLLs into the game directory). I didn't think this would work, as the crash was always in "atioglx.dll", pointing to the video driver, but I wanted to make sure.

I also tried a few of the other standard fixes for this kind of thing: Windows XP compatibility mode, disable desktop composition, run as administrator, etc., but nothing helped.

I did, however, manage to find a semi-solution. The game would load for a few seconds before crashing, and knowing it was a video problem I tried the only possible change left to me: forcing windowed mode. Quickly pressing Alt+Enter while it was loading made it go into windowed mode before the graphics engine was initialized. And, voila, the game doesn't crash when windowed!

Anyway, for reference I have:

Windows 7 64Bit
AMD Phenom II X4 965 (3.4Ghx quad core, OC'd to 3.9-4.0)
16 GB Ram
2x Radeon HD 6870 1GB VRam (and, yes, I tried disabling Crossfire)

Mostly latest ATI drivers. I forget the exact version but it's something like 11.5 Hotfix 2...

I did get a BSOD later, after playing for a bit, but that may be unrelated. I'm waiting for ATI to hurry up and release some new stable drivers...

Anyway, thoughts on further troubleshooting?


TL;DR: Forcing windowed mode with Alt+Enter prevents crashing on load with ATI + Windows 7!

Shadow
06-17-2011, 11:18 AM
It's most likely graphics driver related so update your drivers whenever you can.

Some other things you can try: turn off ATI Tray tool's on-screen-display
(it shows fps for any 3D application), turn off Triple buffering, and turn off anti-aliasing.

Sarkazein
06-26-2011, 05:54 PM
Heya,

Ended up buying DC for both platforms. Retail DC+DW 1.024 still crashes if it's fullscreen.

I don't have ATI Tray Tools installed at the moment, so it's not that. I've also experimented with disabling AA/AF and forcing Triple Buffering, but those never solved the problem.

Game still works great windowed, so it's a small price to pay. I'm going to be updating my drivers to 11.6 soon so I'll post back if that changes anything.

Shadow
06-27-2011, 08:19 AM
Hopefully the new drivers will help out. As for the triple buffering stuff, you want that off.

Sarkazein
07-08-2011, 01:30 AM
Heya, just an update to let you know the ATI 11.6 drivers haven't solved the problem. I also made sure I wasn't forcing triple-buffering or vsync or anything. Windowed mode still works great though.

abomination5
10-16-2011, 10:23 PM
I had this issue but disabling triple buffering in the ATI utility fixed it.