PDA

View Full Version : Beta patch 1.005 available


Shadow
01-06-2008, 12:14 PM
The 1.005 beta patch for Depths of Peril is now available. As usual the patch is available on our patch page (http://www.soldak.com/Depths-of-Peril/Patches.html) and you can see a list of all of the changes here (http://www.soldak.com/Depths-of-Peril/Patches/Changes.html).

ShaggyMoose
01-06-2008, 02:47 PM
When you say you fixed an item, do you mean you fixed the text description or something else?

Shadow
01-06-2008, 03:15 PM
In the case of patch 1.005, I think those particular items were completely broken and would never spawn at all.

Delve
01-06-2008, 04:59 PM
Two text bugs. Presumably related to the localization changes. See images.

http://img184.imageshack.us/img184/3237/cryspromptkx0.th.jpg (http://img184.imageshack.us/my.php?image=cryspromptkx0.jpg)

http://img184.imageshack.us/img184/7480/trdrtemsguk5.th.jpg (http://img184.imageshack.us/my.php?image=trdrtemsguk5.jpg)

Oh yeah, I also can't use my numpad keys to enter trade amounts anymore. I did verify my numlock is on. :)

Desticato
01-06-2008, 05:09 PM
I mistakenly posted about an issue with text formatting here:

http://www.soldak.com/forums/showthread.php?t=395

I'm mostly okay with it being included in a thread with the topic of 'bug or not' but I had intended to create an entirely new post.

I couldn't actually get to the pics that you posted, but I'm assuming we're reporting the same (or similar) problem.

Delve
01-06-2008, 05:20 PM
Yes, I expect they're similar bugs. Different instances of the same error.

Shadow
01-06-2008, 05:43 PM
Yes, anytime you see $$ or ## stuff it's a localization bug.

SamMcMackin
01-06-2008, 05:50 PM
The bookshelf still says that it is a shared stash... or is it just me?

Did you change anything in the graphics department? It seems that my game runs much smoother now... maybe it was because I just did a restart?

Shadow
01-07-2008, 08:25 AM
That's strange. I just checked on my test computer and it shows the new text. Are you still running the old executable somehow?

Delve
01-07-2008, 12:05 PM
I may be mistaken, but it appears that quotes and apostrophes are being stripped from the history books now. I know there was missing punctuation prior to 1.005, but I thought it was mostly there. When I tried to read Looking Red the Crystal's Cry for the first time last night there were no apostrophe or quote marks in the text (the title was fine). Made it rather confusing.

I don't have specific examples, but if I can install the 1.004 patch over 1.005 without damaging anything I could check punctuation in that version.

Shadow
01-07-2008, 02:25 PM
You should be able to install 1.004 just fine to go back a version. This isn't always true because the save game format could have changed.

Delve
01-07-2008, 03:55 PM
Yeah, I know. That's why I was asking. Here you go:

V 1.004
http://img218.imageshack.us/img218/7202/ver1004tf1.th.jpg (http://img218.imageshack.us/my.php?image=ver1004tf1.jpg)

V beta 1.005
http://img504.imageshack.us/img504/6884/ver1005fh9.th.jpg (http://img504.imageshack.us/my.php?image=ver1005fh9.jpg)

Please note that those are just the ones on the first page of text, there are no apostrophes or quotes throughout the entire book in beta ver 1.005.

Shadow
01-07-2008, 07:20 PM
Good catch on all of these guys. The missing ' and " in the stories, the select crystals amount, ##3# trade route, Nightmare item, and Lulan's Flail are all fixed in version 1.006 (along with some others that I found).

If you see any more of these yell at me and I'll get them fixed. I think for a change I'm going to go straight to beta 1.006 to fix as many of these as possible (hopefully tomorrow).

Delve
01-08-2008, 04:54 AM
I'm getting symbols in the field display item description on magestaff items. You may've already fixed these, I think they also have a broken damage range display. I can get screenshots if you want, I've been getting them rather often of late.

Also, I've seen flaws in item requirements as well, but I don't recall all the details. I'll start taking better notes, sorry. :)

Shadow
01-08-2008, 10:25 AM
The magestaff one is fixed also. It just happens to be the same thing that is breaking the Nightmare item (unique staff).

Delve
01-08-2008, 11:17 AM
I noticed. I just found a Nightmare a few minutes ago. Now safely tucked into the hands of one of my mage recruits. :)