PDA

View Full Version : Portal bugs


Delve
01-09-2008, 07:23 AM
This has happened to me 2 times now. The basic bug is, you enter a portal of some type and get teleported to somewhere semi-random.

Here's the circumstances of each instance as best I can remember.
1) I'm raiding someone. Another covenant joins the fray, and I decide to step out for a minute. I accidentally click on the other covenant's raid gate several times (which may be the cause, since all of this started after this event). I eventually get it right and the covenant I'm raiding gets eliminated. When I try to use my player gate I end up TPed to the far left corner of Jorvik instead of lvl 2 of torment dungeon. I run back home and use the covenant gate assuming mine is just messed up. When I get where I'm going and try to open another player gate the game crashes with an access violation.

2) Same game world. I'm running around (again this is after a raid with multiple attacking covenants, but there are no active raids on) and decide to follow a quest lead into the torment dungeon (notice the same dungeon). I enter from the exterior zone and end up in a void. A void that just happens to have all 4 of my covenant's relics sitting on the ground (which I pick up before realizing what's happening). There are also a lot of sparkly monster effects going on, which I assume to be the sparklies that my elite guards would normally have if the weren't guard monsters. All visible effects are centered on the screen, I should have taken a screenshot. I can't walk anywhere, and I'm told I can't create a gate so I try to save and exit. The game immediately crashes with an access violation.

When I loaded back up after that last crash I realized that the relics I picked up from the void are the same as the relics installed in my house. Which is when I started thinking the sparklies were from my guards. So currently I've got 4 relics installed in my house and 4 relics in my inventory which are possibly duplicates and possibly horribly broken references to my house relics.

So, what do I do now?

ShaggyMoose
01-09-2008, 08:10 AM
Wow. That's a mess.:o

Shadow
01-09-2008, 09:42 AM
Yeah, that's really strange. Unless the bug is repeating for you each game, I wouldn't worry about it too much. The duplicated relics should be good items. If you are really worried about it, you can always back up your characters directory.

Delve
01-09-2008, 10:17 AM
No worries. It's only happened to me in this one world, if it carries on and gets burdensome I'll abandon the world and try again. Thanks :)

FloodSpectre
01-13-2008, 05:51 PM
This has also happened to me four times with one character across two worlds in v 1.006, and once in 1.004 with a different character/world. I get teleported somewhere somewhat random, make a new portal and get an access violation crash (0x0042569A tried to read from 0x00000004).

Oh, and several of these instances involved the Torture Dungeon, I think it was called.

Delve
01-13-2008, 05:54 PM
As a followup, this has (mostly) stopped happening to me since I cleaned up my drive. I had, uh, no free space left. :eek:

It still happens occasionally in that one dungeon, which makes me think that portion of my world file might be corrupted somehow, but I don't intend to venture back there again now that I've outleveled it anyway. :)

FloodSpectre
01-13-2008, 10:50 PM
I've had the crash two more times today. I don't think it's as Delve says, at least not for me. I'm at 36 free gigs on my HD and at a very low fragmentation. Also, on a different world than before. The most recent crash was different, with no error message, just a complete drop back to Windows. I had a strong feeling this would happen this time though, because the gate said "Gate To" and no area name.

(name here)
01-13-2008, 11:06 PM
i've had the access violation and occasional vanishing portals.

Shadow
01-14-2008, 11:45 AM
I'll look and see if I can figure out what is going on with the portals.

SuperSayu
01-19-2008, 08:12 PM
First post... only really joined the forums to help chase down bugs. Love the game.

I had a similar problem to the one described... in that it had similar results, but a completely different starting point. Basically, I was in Wicked Desert, and when I clicked on the gate to go to Sullen Crypt L1, I got warped to the lower-left corner of Jorvik. I did NOT try again, and therefore didn't get the crash, instead I immediately saved and exited, and restarted the program. Currently it seems to be working again. In terms of context, the only thing I can think of that might be relevant is that I had been gate hopping just before, and came out of a player gate and immediately clicked on the entrance with almost no delay. Maybe something was supposed to load and didn't?

I am using 1.006.

Shadow
01-20-2008, 10:33 AM
Yeah, that should be fixed in 1.007.

Edwin DeNicholas
01-20-2008, 09:01 PM
I haven't seen the weird portal to the corner of Jorvik bug since 1.007, however the portal then crash bug has happened at least 6 times today. The worst was when I took the secret area portal. I saw maybe 4-5 chests and just as I started to smile with glee, being drunk on +treasure find potions, the game crashed :(