PDA

View Full Version : Compressed Texture Bug?


stumbler
01-12-2008, 09:53 PM
Game: Running with compressed textures on a Nvidia 7900 GT, Driver Date 12/5/2007, Driver Version 6.14.11.6921.

Version 1.004

In the Options Menu, with *Compressed Textures* the menu area behind the buttons is covered with vertical black and white bars. This problem does not exist when texture compression is turned off.

Send and email if you want more details about anything. Partial screen shot attached.

Shadow
01-12-2008, 10:30 PM
This should be fixed in version 1.007.

McGlu
01-19-2008, 08:11 PM
The bars went away for me from a couple background screens with 1.007, but I'm still seeing them in the XP bar, and the Kick from Covenant icon has them.

Windows Vista, nVidia 7950 GT (driver 169.25).

Disabling Compress Textures fixes the problem.

What are the implications of disabling this feature? Besides the game taking a little longer to load, perf seems about the same.

http://www.guilduniverse.com/userfiles/0000/1/images/DoPBars.jpg

stumbler
01-19-2008, 11:32 PM
Compressed texture bug still exists in 1.07 :(

Shadow
01-20-2008, 10:29 AM
Is your compressed texture problem still the same or is it like McGlu and some spots are fixed but there are others that are still broken?

stumbler
01-20-2008, 11:04 AM
"The Bars" show up (in 1.007) in the following places (only when compressed textures on on.)

1) The Background on the Options Page

2) In the "experience bar" , but only on the the right side which in not filled with XP yet

3) On the Henchmen Screen, over the "Kick NPC Out of Covenant Button"

4) Over the Covenant Icon on the covenant actions menu after you click a covenant on the covenant relations screen.

5) When you click Trade Items: Over the covenant icon and covenant "feedback text" on the Trade Items screen

6) When you click Trade: Over the covenant icon and large feedback text on the "Trade" menu (where you can declare war)

NVIDIA 7900/GT
256MB
Driver Version: 6.14.11.6921 (12/5/2007)

Hope this helps.

McGlu
01-20-2008, 05:08 PM
I checked everything that stumbler listed on my computer, and the only two I see are the ones that I posted earlier (#2 and #3).

Edwin DeNicholas
01-20-2008, 09:02 PM
I have the same as McGlu. Vertical lines on the XP bar and Kick From Covenant button.

Shadow
01-22-2008, 11:04 AM
stumbler it sounds to me like you might have those textures that I fixed as loose files now, so it's not using the new ones in the patch. Moving back and forth from compressed and uncompressed can make the game generate the different formats of the files.

Make sure the game is using compressed textures first. Then go to the Depths of Peril/Assets/Textures/UI directory and see if you have the files cave.rtx, cave_right.rtx, uibubble2_drk.rtx, cave.ctx, cave_right.ctx, and uibubble2_drk.ctx. If you do, move them to a temp directory or something to get them out of the way and then run the game again. If you do this hopefully it will get rid of some of the stripe errors.

stumbler
01-22-2008, 10:29 PM
This seemed to work for most of the lines! Thanks!

Remaining issues include:
1) Right side of XP Bar
2) Kick NPC out of Covenant Button

McMurlock
02-09-2008, 08:19 AM
Is it possible to update demo with the fix ?


With Texture compressed on, I've the blank lines and with off, All gfx are garbage. The demo seems to be 1.002

Thanks,
McMurlock

Delwynndwn
03-13-2008, 03:51 PM
I've found that the textures used for the icons for champion, elite, unique, boss, etc. monsters have the stripes through them when compressed. I'm sure this is the same problem that's been had with other textures in previous versions.

Using a GeForce Go 6600
256 MB, PCI Express
Driver version: 6.14.11.6909

Currently using DoP 1.009

Delwynndwn
03-27-2008, 08:49 PM
An addendum to my above post, I've noticed the icons for when the town is under attack (both by siege tower and dimensional gate, IIRC) have the vertical white stripes as well.

Same hardware and DoP version as the above post.

Shadow
03-28-2008, 09:43 AM
I've apparently been a little lax in updating some of these threads. The current demo on our website should have fixed most of the stripe textures issue since the new demo is version 1.009.

Also, the monster rarity icons will be fixed in version 1.010. I'll look at the town attack icons. Assuming they are the same problem they should be easy to fix.