PDA

View Full Version : Beam effects not playing.


Krippakrull
06-15-2012, 06:26 PM
Bought all the other games from Soldak and now I jumped the wagon and preordered Drox. I am a big space junkie and an ARPG set in space with a 4x running in the background might be one of the most wonderful ideas ever.

Having played a few hours, I really love what I have seen so far, but I have run into a bug that might be hardware/driver related or something since I haven't seen anyone else mention it:

For some reason, after a period of playing the game my fusion beam starts acting wonky. The beam itself with its assorted sound effect stops playing. I still score hits and do damage fine, and the "clonk" sound for hitting a ship plays. It isn't the end of the world, but very annoying to be honest.

My specs are a GeForce 560 Ti with the latest drivers, Win 7 64-bit, integrated Realtek audio and 8 gigs of RAM. My DxDiag is also attached (zipped since it was larger than the .txt limit).

Shadow
06-15-2012, 06:57 PM
That's strange. Is it just your beam that stops playing or is it all beams?

Zenchess
06-15-2012, 07:08 PM
I purchased the game for myself and a friend. We've been playing multiplayer and have this same issue. It worked fine for quite a while but then after an hour or so of playing beams stopped firing (possibly rockets too) and the damage was just dealt without any effect. Sometimes the beams will display, approximately 1 out of 5 hits or what not will show the beam and the rest just shows the damage.

We tried restarting the server, which didn't help (playing on the same world). We haven't tried starting a new world yet.

Eagleheart
06-15-2012, 07:33 PM
I was just about to post this problem myself when this thread went up. It was happening for both me and a friend in a co op game. We saved and quit the game and loaded it back up and it was still doing it for both of us, so this is a very annoying issue indeed.

Krippakrull
06-15-2012, 07:37 PM
*slaps forehead* It seems like it has nothing to do with playtime, but rather all weapon effects starts behaving wonky after I have alt-tabbed out of the game. It is late now though, I will do a longer session without tabbing out tomorrow just to make sure.

ShaggyMoose
06-16-2012, 12:19 AM
I Alt + Tab out of all the time without having this issue. I wonder if its a particular configuration that causes it?

Krippakrull
06-16-2012, 07:04 AM
Having played a bit more it seems to happen irregardless if I Alt-Tab out of the game or not. It effects all weapons too.

My in game options are maxed out. Have tried enabling and disabling AA and Anisotropic Filtering as well as play with the effect detail slider to no avail. I am wondering if it could be a sound issue, since neither the audio or visual effect is being played.

Krippakrull
06-16-2012, 12:18 PM
I also wonder if this has something to do with the fact that my console is full of "Couldn't add entity, too many entities." when I bring it up or if that's something else.

Shadow
06-16-2012, 12:23 PM
I also wonder if this has something to do with the fact that my console is full of "Couldn't add entity, too many entities." when I bring it up or if that's something else.

That's probably the problem. What sized sector are you playing in?

Krippakrull
06-16-2012, 12:25 PM
Normal sized sector I believe.

oznogg
06-16-2012, 01:26 PM
Same issues here. I've found two major problems, as well.

This issue started happening for me when I had both a nuclear missile weapon and and EMP installed. For some reason, if I only use missile weapons, everything runs fine. The moment I start using EMP, the visual effects stop working. I have repeated this bug twice with both Hive and Dryad.

To make matters worse, loot stops appearing when the visuals glitch out. Exploring a new planet, I get the message "You found a hidden stash of ship componenets", yet nothing drops. Monsters also stop dropping loot, and the same issue happens with anamolies.

I would be more than happy to share my save games, if it helps.

aReclusiveMind
06-17-2012, 03:23 AM
I also wonder if this has something to do with the fact that my console is full of "Couldn't add entity, too many entities." when I bring it up or if that's something else.

I am seeing this in my console as well. It seems that when there are a lot of enemies around and I start blasting them, my missiles/lasers/etc no longer appear and ships just kind of vanish when I kill them instead of blowing up properly.

NefariousKoel
06-17-2012, 12:41 PM
I've been getting my weapon sounds & explosions cutting out, too.

This has been happening when I use my onboard sound drivers, but not when I use my USB headset that uses it's own separate sound drivers. Alt-tabbing out, and then back in, briefly resets it back to normal (for a couple minutes).

So this keeps cutting out for onboard sound; probably the most common sound chipset used - Realtek HD audio.

Jinsai
06-17-2012, 01:36 PM
Also having this problem. Not sure what it's related to, but I had been playing for several hours before it happened.

oznogg
06-17-2012, 04:29 PM
I am having similar issues. The problem is worse than it seems, however. Stashes will no longer drop items, at least, I am under the impression the animation is failing, so the items do not appear. This is true for killing monsters at well, they no longer drop loot.

Once the glitching starts, it can only be remedied completely by starting a new game, I've found. It's a workaround, but kinda destroys the idea of finding loot to improve your ship.

It seems this bug emerges much more commonly for AoE items.

NefariousKoel
06-18-2012, 01:37 AM
So the some piece of code in weapon firing is bugging out and the rest of that series of events isn't firing, I guess..?

Shadow
06-18-2012, 04:16 PM
I did a few things in patch 0.901 that should help this out. Are you guys seeing the problem any more with the latest patch?

oznogg
06-18-2012, 04:46 PM
I am personally no longer having the issues any longer. It is really hard to tell if loot is not spawning because the game has too many entities on the screen (if this was, in fact the issue). This could make fights near major outposts pretty meaningless late game.