PDA

View Full Version : Crash Report


nefariousD
08-21-2007, 12:33 AM
Weee! Having a blast with this game. What a way to start a crash report, eh? :)

Declared war on a covenant to woo the leader, was in the process of raiding when I had a crash. The log file was short and sweet so i'll just paste it in:

Initializing networking
RPG Version 0.881

Opened Generic Software Device
Using 256 sound sources
Sound system initialized
OS: Home Edition (Build 6000)

CPU Type: AuthenticAMD
CPU Name: AMD Athlon(tm) XP 2600+
CPU Features: FPU, MMX, SSE, 3DNOW, 3DNOW+, TSC, CX8, CMOV, VME, DE, PSE, MSR, PAE, MCE, APIC, SEP, MTRR, PGE, MCA, PAT, PSE36, FXSR
Sound card: Speakers (C-Media USB Headphone
RAM: 1534 MByte!
Input initialized
Debug system started
Input initialized
Couldn't find Sounds/Monsters/Torva/taunt.wav
Couldn't find Models/Creatures/Torva/Data/torva_torture.ctx
Couldn't find Models/Creatures/Hellhound/Data/hellhound_hellhound.ctx

Shadow
08-21-2007, 10:39 AM
Thanks nefariousD, I'll try to track this down.

Another helpful bit of data on crashes is the crash address. Usually you can find this somewhere on the crash popup that windows puts up. You basically need to choose the more info link (in XP it says "To see what data this error report contains, click here") and then tell me what the ModName and Offset values are.

nefariousD
08-21-2007, 11:56 AM
Just as a side note, I checked for the resources listed in the error and they are not in the asset zip! The file names are different, albeit similar. This is surely why it complained about not finding them :)

Shadow
08-21-2007, 12:23 PM
Yeah those 3 particular assets aren't in the demo, but they shouldn't be the cause of the crash. The game can handle missing textures and sounds. The sounds just won't play and the textures will show up mostly white.

I have fixed these in the full release though.