PDA

View Full Version : Just bought the game but...


rifkin
09-05-2007, 07:38 PM
I cant run it. I have vista 32bit and i keep getting depthsofperil.exe has stopped working. Here is the
Application error message that i get:

Description:
Faulting application DepthsOfPeril.exe, version 0.0.0.0, time stamp 0x46dd7f1e, faulting module unknown, version 0.0.0.0, time stamp 0x00000000, exception code 0xc0000096, fault offset 0x00e938d8, process id 0xf74, application start time 0x01c7f00cacbf4bf5.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2007-09-05T22:32:43.000Z" />
<EventRecordID>3908</EventRecordID>
<Channel>Application</Channel>
<Computer>User-PC</Computer>
<Security />
</System>
<EventData>
<Data>DepthsOfPeril.exe</Data>
<Data>0.0.0.0</Data>
<Data>46dd7f1e</Data>
<Data>unknown</Data>
<Data>0.0.0.0</Data>
<Data>00000000</Data>
<Data>c0000096</Data>
<Data>00e938d8</Data>
<Data>f74</Data>
<Data>01c7f00cacbf4bf5</Data>
</EventData>
</Event>

The strange thing is that the demo runs fine but when i try
to run the full game i get this error.

Shadow
09-05-2007, 07:49 PM
Can you add the following line to your user.cfg file in the User directory?
logfile 2
Then run the game and then post the log.txt file.

rifkin
09-05-2007, 08:01 PM
Thats strange i dont seem to have a user.cfg all i have is the default.cfg.

Shadow
09-05-2007, 08:09 PM
It must not be getting far enough to generate one. In that case, just create the user.cfg file and add logfile 2 as the only thing in it.

rifkin
09-05-2007, 08:12 PM
i tried that but still dont get a log i can give you my log from the demo version if that helps.

Shadow
09-05-2007, 08:15 PM
Did it ask for your name and security key?

rifkin
09-05-2007, 08:22 PM
nope dosen't even get that far

Shadow
09-05-2007, 08:28 PM
It sounds like something is corrupted or the protection stuff is having a problem. Is DepthsOfPeril.exe 1,589,248 bytes? You don't happen to use AOL do you?

rifkin
09-05-2007, 08:33 PM
Yep its 1,589,248 bytes and i use firefox perhaps i will try to reinstall vista could be the culprit.

Shadow
09-05-2007, 08:38 PM
I asked about AOL because whatever spyware program they use has screwed up the protection stuff we use in the past. So if you are using any spyware, just as a test you might want to turn it off temporarily.

Shadow
09-06-2007, 09:32 AM
Did you get it working?

rifkin
09-06-2007, 02:10 PM
its all good now i got it working by reinstalling vista

Shadow
09-06-2007, 03:34 PM
Great! It sounds like this is an isolated case, but I'm still sorry that it took so much effort to get the game working. :( I hope you enjoy the game though.

Oh, I forgot to mention, welcome to the forums rifkin.

Quitch
09-10-2007, 04:21 PM
Same error here:

Log Name: Application
Source: Application Error
Date: 10/09/2007 19:58:04
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: Pokey
Description:
Faulting application DepthsOfPeril.exe, version 0.0.0.0, time stamp 0x46dd7f1e, faulting module unknown, version 0.0.0.0, time stamp 0x00000000, exception code 0xc0000096, fault offset 0x003438d8, process id 0x13d4, application start time 0x01c7f3dc84316c49.

Running under Vista Ultimate 32bit. Demo worked fine, full game doesn't.

Downloaded twice, same problem each time. I used Mozilla Firefox 2.0.0.6 en-gb version.

It doesn't ask for my username or security key.

I manually created user.cfg and added logfile 2, but not log.txt is generated.

I've attached my dxdiag config.

Quitch
09-10-2007, 06:29 PM
For those experiencing this problem, it seems to be DEP related. You need to add DepthsOfPeril.exe to the DEP exceptions list.

You have to have enabled DEP for all apps in the first place, so if you don't know what DEP is then you have no fear.

Thanks for Steven for his help with this.

Shadow
09-10-2007, 06:35 PM
Ok, if you are running Vista and the first time you try to run the game and it crashes before it even asks you about your name and security key you probably have this issue. If you are follow the steps below and it should fix the problem.


Go to Control Panel->System and Maintenance->System (I think you can get
here by doing a View Computer Details too).

Select "Advanced system settings" (User Account Control may kick in and ask
for permission to continue)

On the "Advanced" tab under Performance, Click Settings.

Then select the "Data Execution Prevention" tab.

Select the top radio button "Turn on DEP for essential Windows programs and
services only".
(You can also just add the application to the list box below the second
(default) radio button)

Click Apply and OK's to back out, then restart Vista.